Mailgun Website Intermittent Issues
Incident Report for mailgun
Resolved
Today, at approximately 9:00 UTC, the mailgun.com webpage began issuing redirects to sites outside of our domain. We immediately launched an incident to determine the source of the redirects and determined that a plugin for WordPress was responsible for issuing the redirects. We've disabled the plugin responsible for this issue.

Our applications including the Mailgun Dashboard, APIs, and customer data stored on our platform were not impacted by this issue.
Posted Apr 10, 2019 - 04:20 PDT
Update
We are continuing to investigate this issue.
Posted Apr 10, 2019 - 03:15 PDT
Investigating
We have identified an issue with our Mailgun website redirecting to different URLs, we are currently investigating.
Posted Apr 10, 2019 - 02:25 PDT
This incident affected: Customer Tools (Control Panel).