Sending errors in US

Incident Report for mailgun

Resolved

All systems are operating normally at this time. Our engineers continue to monitor our systems for any recurrence or new issues.
Posted Sep 12, 2025 - 08:21 PDT

Update

Systems have normalized, we are continuing to monitor for any issues.
Posted Sep 12, 2025 - 07:48 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 12, 2025 - 06:57 PDT

Update

Error rates are normalizing as we continue to work to fix the issue.
Posted Sep 12, 2025 - 06:42 PDT

Identified

We are continuing to work to stabilize things at this time. We have no ETA.
Posted Sep 12, 2025 - 05:57 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 12, 2025 - 05:03 PDT

Update

We are continuing to investigate this issue.
Posted Sep 12, 2025 - 04:14 PDT

Update

We are continuing to investigate this issue.
Posted Sep 12, 2025 - 03:49 PDT

Update

We are continuing to investigate this issue.
Posted Sep 12, 2025 - 03:28 PDT

Investigating

We are currently investigating reports of sending errors in US regions.
Posted Sep 12, 2025 - 03:07 PDT
This incident affected: Email Services (API).