Intermittent Control Panel Timeouts
Incident Report for mailgun
Resolved
The timeouts affecting the Control Panel for some users have cleared, and the issue is resolved.
Posted 10 days ago. Aug 09, 2019 - 14:07 PDT
Investigating
We are investigating problems with the Control Panel not loading for some users.
Posted 10 days ago. Aug 09, 2019 - 11:37 PDT
This incident affected: Control Panel.