Delayed Logs in US Region

Incident Report for mailgun

Resolved

Events are processing normally.
Posted Nov 28, 2025 - 09:56 PST

Monitoring

Events are processing normally, we continue to monitor as we see elevated send volumes.
Posted Nov 28, 2025 - 09:19 PST

Identified

Logs are currently experiencing delays of 15 minutes in Mailgun's US region. Outbound processing, inbound processing, and webhook delivery are operating normally.
Posted Nov 28, 2025 - 08:30 PST
This incident affected: Email Services (Events & Logs).