Automatic Sender Security Records Not Provisioning

Incident Report for mailgun

Resolved

This incident has been resolved.
Posted May 07, 2026 - 11:42 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 07, 2026 - 05:40 PDT

Update

We are continuing to work on a fix for this issue.
Posted May 06, 2026 - 12:46 PDT

Identified

Customers creating domains with Automatic Sender Security may have CNAME records with no corresponding TXT records reflecting DKIM keys. A fix for this issue is being prepared.
Posted May 06, 2026 - 08:40 PDT
This incident affected: Customer Tools (Control Panel).