GCP Reporting Multi Service Outage in US-West1

Incident Report for mailgun

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 10:31 PDT

Update

GCP has put a mitigation in place, we are monitoring the results. At this time we are experiencing no impacts. All delayed webhooks and logs have been processed.
Posted Aug 20, 2026 - 10:09 PDT

Update

Outbound delivery is operating normally. Currently there are delays for event logs and some webhooks.
Posted Aug 20, 2026 - 09:30 PDT

Monitoring

Mailgun is monitoring service impacts in GCP's us-west1 region. We are routing traffic away from impacted infrastructure. Currently we are seeing delays in log processing and a small number of message sends.
Posted Aug 20, 2026 - 09:19 PDT
This incident affected: Email Services (Outbound Delivery, Events & Logs).