Intermittent Control Panel Errors
Incident Report for mailgun
Resolved
This incident has been resolved.
Posted 8 months ago. Oct 21, 2018 - 19:58 PDT
Monitoring
We have deployed a fix and are currently monitoring the situation.
Posted 8 months ago. Oct 21, 2018 - 17:55 PDT
Investigating
We are currently investigating intermittent errors within the control panel for some users.
Posted 8 months ago. Oct 21, 2018 - 17:05 PDT
This incident affected: Control Panel.