Logins from Rackspace / Heroku
Incident Report for mailgun
Resolved
This incident has been resolved.
Posted Jun 18, 2020 - 11:22 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 18, 2020 - 09:28 PDT
Investigating
We're currently investigating an issue with control panel logins coming from Rackspace and Heroku
Posted Jun 18, 2020 - 07:24 PDT
This incident affected: Customer Tools (Control Panel).