Login issues
Incident Report for mailgun
Resolved
This incident has been resolved.
Posted May 02, 2024 - 01:01 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 02, 2024 - 00:50 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 02, 2024 - 00:18 PDT
Investigating
We are investigating reports that some customers are unable to login to app.mailgun.com
Posted May 01, 2024 - 23:41 PDT
This incident affected: Customer Tools (Control Panel).