Degraded performance

Incident Report for mailgun

Resolved

This incident has been resolved.
Posted May 19, 2025 - 15:28 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 19, 2025 - 14:48 PDT

Identified

We have identified an issue with one of our datastores and are attempting to implement a fix.
Posted May 19, 2025 - 14:33 PDT

Investigating

We are currently investigating reports of degraded performance.
Posted May 19, 2025 - 14:27 PDT
This incident affected: Email Services (API, SMTP, Outbound Delivery, Inbound email processing, Events & Logs, Stats and Analytics) and Deliverability Services (Email Validation, Inbox Placement, Spam Trap Network, Email Previews).