Partial Delay in Event Processing for US Region

Incident Report for mailgun

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 03:24 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 18, 2026 - 03:11 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 18, 2026 - 02:53 PDT

Update

We are continuing to investigate this issue.
Posted Jun 18, 2026 - 02:11 PDT

Investigating

Customers using the events/logs APIs or viewing logs in the customer portal may see delays in some events appearing. These delays are only affecting a subset of our customers.
Posted Jun 18, 2026 - 01:34 PDT
This incident affected: Email Services (Events & Logs).