Intermittent API Errors

Incident Report for mailgun

Resolved

This incident has been resolved.
Posted May 14, 2025 - 15:18 PDT

Monitoring

A fix has been deployed and we are monitoring.
Posted May 14, 2025 - 15:03 PDT

Identified

We identified a routing issue in our internal service mesh. We are attempting to roll out a fix.
Posted May 14, 2025 - 14:32 PDT

Update

We are continuing to investigate this issue.
Posted May 14, 2025 - 14:08 PDT

Update

We are continuing to investigate this issue.
Posted May 14, 2025 - 13:41 PDT

Update

We are continuing to investigate this issue.
Posted May 14, 2025 - 12:12 PDT

Update

We are continuing to investigate this issue.
Posted May 14, 2025 - 11:48 PDT

Investigating

We are currently investigating this issue.
Posted May 14, 2025 - 11:38 PDT
This incident affected: Email Services (API, SMTP), Customer Tools (Control Panel), and Deliverability Services (Email Validation).