Login Issues to Mailgun and intermittent connection issues to api.mailgun.net
Incident Report for mailgun
Resolved
This incident has been resolved.
Posted Feb 13, 2024 - 08:01 PST
Update
We are continuing to monitor our systems. All impacts of this attack have been mitigated at this time.
Posted Feb 13, 2024 - 05:40 PST
Monitoring
A mitigation has been put in place to restore the functionality of our login page. We are continuing to monitor the DDOS attack.
Posted Feb 12, 2024 - 17:50 PST
Update
We are continuing work to mitigate impact to our login page. More updates will be provided when information becomes available.
Posted Feb 12, 2024 - 12:27 PST
Update
Our cloud provider is working through internal escalation process to help us with the mitigation, meanwhile we are working on scaling up the infrastructure to support the load.
Posted Feb 12, 2024 - 09:24 PST
Update
We are working with our cloud provider on possible mitigation strategy.
Posted Feb 12, 2024 - 06:45 PST
Identified
We are seeing a DDOS attack against our login page and we have deployed mitigation changes to improve the experience for the legitimate users, still working on complete resolution.
Posted Feb 12, 2024 - 04:33 PST
Update
We are continuing to investigate this issue.
Posted Feb 12, 2024 - 02:41 PST
Investigating
We are currently investigating intermittent issues logging into the Mailgun control panel.
Posted Feb 12, 2024 - 01:06 PST
This incident affected: Email Services (API) and Customer Tools (Control Panel).