EU Sending Delays

Incident Report for mailgun

Resolved

This incident has been resolved.
Posted Nov 09, 2021 - 01:38 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 09, 2021 - 01:13 PST

Identified

Sending queue is starting to reduce
Posted Nov 09, 2021 - 00:42 PST

Investigating

Mailgun EU is experiencing sending delays
Posted Nov 09, 2021 - 00:11 PST
This incident affected: Email Services (Outbound Delivery, Inbound email processing).