smtp.trans delays
Incident Report for mailgun
Resolved
This incident has been resolved.
Posted Apr 18, 2021 - 09:53 PDT
Update
We are continuing to investigate this issue.
Posted Apr 18, 2021 - 09:32 PDT
Investigating
There are currently message delays impacting a small portion of messages for SMTP processing
Posted Apr 18, 2021 - 09:32 PDT
This incident affected: Email Services (SMTP).