EU message delivery failures
Incident Report for mailgun
Resolved
This incident has been resolved.
Posted Oct 31, 2023 - 19:49 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 31, 2023 - 19:31 PDT
Monitoring
The issue has been addressed. Monitoring continues.
Posted Oct 31, 2023 - 19:31 PDT
Identified
The issue has been identified.
Posted Oct 31, 2023 - 19:09 PDT
Investigating
We are currently seeing an increase in failed email delivery in our EU region. Investigation is ongoing.
Posted Oct 31, 2023 - 17:49 PDT
This incident affected: Email Services (Outbound Delivery).