User Login Failure
Incident Report for mailgun
Resolved
The disruption affecting user logins has been resolved, and logins to our platform are completing successfully.
Posted about 1 month ago. Jul 10, 2019 - 16:13 PDT
Investigating
We are currently investigating issues impacting user logins to our control panel.
Posted about 1 month ago. Jul 10, 2019 - 15:46 PDT
This incident affected: Control Panel.