HTTPS Tracking Certificate Creation / Renewal blocked by Let's Encrypt Outage

Incident Report for mailgun

Resolved

This incident has been resolved.
Posted Jul 22, 2025 - 04:33 PDT

Monitoring

The current status of Let's Encrypt infrastucture is "[Identified] We have deployed mitigations for the failure of our internal DNS servers. Issuance of certificates is now succeeding, though we are still recovering from the resulting high traffic volumes."

We are monitoring the situation and will update our status page accordingly.
Posted Jul 21, 2025 - 22:22 PDT

Identified

Let's Encrypt, the certificate issuer used for creating certificates on customer tracking domains is experiencing an outage (https://letsencrypt.status.io/). Attempting to generate or regenerate a tracking certificate will not succeed until service is restored.
Posted Jul 21, 2025 - 16:56 PDT
This incident affected: Email Services (API).