Event queues have caught up and events are processing normally.
Posted Aug 31, 2026 - 15:01 PDT
Update
The event processing backlog is steadily decreasing, and we’re continuing to monitor the recovery. We expect all delays to be resolved within the hour.
Posted Aug 31, 2026 - 14:28 PDT
Update
The event processing backlog is steadily decreasing, and we’re continuing to monitor the recovery.
Posted Aug 31, 2026 - 13:43 PDT
Update
The event processing backlog is steadily decreasing, and we’re continuing to monitor the recovery. We expect all delays to be resolved in the next 2 hours.
Posted Aug 31, 2026 - 13:13 PDT
Update
The event processing backlog is steadily decreasing, and we’re continuing to monitor the recovery.
Posted Aug 31, 2026 - 12:38 PDT
Update
The delays in event processing are reducing. We expect all delays to be resolved in the next 3 hours.
Posted Aug 31, 2026 - 11:59 PDT
Update
We are putting a fix in place for this issue. There is significant backlogs of event logs to process. We update the expected time of resolution when available.
Posted Aug 31, 2026 - 10:56 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 31, 2026 - 10:05 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 31, 2026 - 09:24 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 31, 2026 - 08:29 PDT
Identified
We are currently experiencing delays in event log processing in our US region.
Posted Aug 31, 2026 - 07:47 PDT
This incident affected: Email Services (Events & Logs).