Delayed logs in US region

Incident Report for mailgun

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 07:15 PDT

Monitoring

A fix has been implemented and we are monitoring results. Outbound processing, inbound processing, and webhook delivery continue operating normally.
Posted Jun 05, 2026 - 07:04 PDT

Investigating

Logs are currently experiencing delays of 15 minutes in Mailgun's US region. Outbound processing, inbound processing, and webhook delivery are operating normally.
Posted Jun 05, 2026 - 06:26 PDT
This incident affected: Email Services (Events & Logs).