Inbox Placement Connectivity
Incident Report for mailgun
Resolved
The issue affecting Inbox Placement has been resolved.
Posted Feb 04, 2020 - 11:52 PST
Investigating
We are currently investigating an issue preventing customers from using Inbox Placement via the API or the UI.
Posted Feb 04, 2020 - 11:18 PST
This incident affected: Deliverability Services (Inbox Placement).