Route delays in EU Region

Incident Report for mailgun

Resolved

All delayed messages have been processed. Systems are operating normally
Posted Jul 24, 2026 - 06:49 PDT

Monitoring

A fix has been implemented and we are monitoring the results. Delayed messages are being processed.
Posted Jul 24, 2026 - 06:18 PDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 24, 2026 - 06:16 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 24, 2026 - 05:38 PDT

Investigating

Inbound messages processed by routes are currently experiencing delays in processing.
Posted Jul 24, 2026 - 05:27 PDT
This incident affected: Email Services (Inbound email processing).