Microsoft Incident Resulting in Delivery Issues to M365

Incident Report for mailgun

Resolved

Microsoft has resolved the underlying issue, we are seeing deliveries to M365 process normally.
Posted Sep 04, 2026 - 05:54 PDT

Update

We are continuing to monitor for any further issues.
Posted Sep 04, 2026 - 05:22 PDT

Monitoring

Starting around 08:00 UTC, Microsoft began experiencing an incident causing an increased volume of deferred emails across all M365 regions. The affected responses are returning "451 4.7.500 Server busy". Our teams are actively monitoring the situation. Sending to other email providers is not affected.
Posted Sep 04, 2026 - 05:20 PDT