Inbound Message Delays
Incident Report for mailgun
Resolved
The delays have been mitigated and the queues are back to normal processing times.
Posted 9 months ago. Sep 08, 2018 - 11:20 PDT
Investigating
We are currently experiencing higher than normal processing times for some inbound messages. Delays with routed messages may be experienced.
Posted 9 months ago. Sep 08, 2018 - 10:50 PDT
This incident affected: Inbound email processing.