SSL connection issues
Incident Report for mailgun
Resolved
This incident has been resolved.
Posted Sep 30, 2021 - 21:35 PDT
Update
We are continuing to monitor the system as it works through the backlog.
Posted Sep 30, 2021 - 18:37 PDT
Monitoring
A fix has been implemented, we are monitoring the results, and the system is currently working through the backlog.
Posted Sep 30, 2021 - 16:27 PDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 30, 2021 - 13:12 PDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 30, 2021 - 12:02 PDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 30, 2021 - 11:08 PDT
Identified
We've identified an issue where TLS connections are failing for webhooks and route notifications. This issue does not affect all endpoints and is limited to endpoints using certificates from certain providers. We're continuing to work towards a resolution.
Posted Sep 30, 2021 - 10:24 PDT
Update
We are continuing to investigate this issue.
Posted Sep 30, 2021 - 10:09 PDT
Investigating
We're currently investigating reports where some SSL connections are failing for webhooks and routes.
Posted Sep 30, 2021 - 09:56 PDT
This incident affected: Email Services (Inbound email processing).