Errors connecting to smtp.eu.mailgun.org

Incident Report for mailgun

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 12:44 PDT

Update

We are continuing to monitor for any further issues.
Posted Mar 17, 2025 - 11:43 PDT

Monitoring

A mitigation has been put in place and SMTP / Inbound email processing in our EU region is back to full working behavior.
Posted Mar 17, 2025 - 08:02 PDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 17, 2025 - 07:22 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 17, 2025 - 04:56 PDT

Update

We are continuing to investigate this issue.
Posted Mar 17, 2025 - 03:29 PDT

Update

We are continuing to investigate this issue.
Posted Mar 17, 2025 - 02:48 PDT

Investigating

We are currently investigating this issue.
Posted Mar 17, 2025 - 02:20 PDT
This incident affected: Email Services (API, SMTP, Outbound Delivery, Inbound email processing).