Degraded Performance with Control Panel
Incident Report for mailgun
Resolved
This incident has been resolved at this time. All systems are operational.
Posted 3 months ago. May 09, 2019 - 14:56 PDT
Monitoring
We have corrected an issue causing intermittent errors in the Mailgun Control Panel, and are monitoring all systems.
Posted 3 months ago. May 09, 2019 - 12:45 PDT
Investigating
We are currently investigating degraded performance within the Mailgun Control Panel at this time.
Posted 3 months ago. May 09, 2019 - 12:27 PDT
This incident affected: Control Panel.