Network Connectivity with Sending Host
Incident Report for mailgun
Resolved
This incident has been resolved.
Posted 9 days ago. Jun 08, 2019 - 19:24 PDT
Monitoring
A fix has been implemented and we are now monitiroing the results.
Posted 9 days ago. Jun 08, 2019 - 16:55 PDT
Investigating
We identified a networking connectivity issue with some of our sending hosts. We’re working with our provider to resolve the issue.
Posted 9 days ago. Jun 08, 2019 - 16:36 PDT
This incident affected: Outbound Delivery.