Outbound Delivery Delays
Incident Report for mailgun
Resolved
This incident has now been resolved and messages are going out within the normal peramiters.
Posted 11 months ago. May 30, 2018 - 08:59 PDT
Monitoring
We have identified an issue where messages with attachments were experiencing delays in being delivered. We have implemented a fix to resolve this issue and will continue to monitor the situation.
Posted 11 months ago. May 30, 2018 - 07:18 PDT
This incident affected: Outbound Delivery.