Elevated 401 errors in US Region

Incident Report for mailgun

Resolved

A fix has been deployed and systems are back to normal.
Posted Mar 19, 2026 - 11:53 PDT

Identified

Some requests may be incorrectly failing with 401 error codes in our US region.
Posted Mar 19, 2026 - 11:43 PDT
This incident affected: Email Services (API).