Message Delays
Incident Report for mailgun
Resolved
This incident has been resolved
Posted over 1 year ago. Mar 05, 2018 - 12:41 PST
Investigating
We are currently investigating an issue that is causing message delays.
Posted over 1 year ago. Mar 05, 2018 - 10:07 PST