Control Panel Intermittently Unavailable
Incident Report for mailgun
Resolved
This incident has been resolved.
Posted Oct 19, 2023 - 11:12 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 19, 2023 - 10:51 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 19, 2023 - 10:39 PDT
Investigating
Mailgun Engineers are investigating issues with app.mailgun.com availability.
Posted Oct 19, 2023 - 10:09 PDT
This incident affected: Customer Tools (Control Panel).