Intermittent connection issues
Incident Report for mailgun
Resolved
This incident has been resolved.
Posted Feb 28, 2023 - 09:20 PST
Update
We continue to closely monitor traffic and are prepared to make additional proactive and reactive infrastructure changes as required.
Posted Feb 27, 2023 - 10:07 PST
Update
We have completed a series of successful infrastructure changes and will monitor traffic closely over the weekend. Unless there is another major development, our next update will be on Monday.
Posted Feb 24, 2023 - 18:38 PST
Update
Still executing against the mitigation strategy and monitoring platform performance.
Posted Feb 24, 2023 - 12:40 PST
Update
We continue to execute against our mitigation strategy and closely monitor platform performance.
Posted Feb 24, 2023 - 07:26 PST
Update
We continue to monitor platform performance.
Posted Feb 23, 2023 - 18:16 PST
Update
We continue to deploy infrastructure updates, both proactive and reactive, while closely monitoring platform performance.
Posted Feb 23, 2023 - 14:52 PST
Update
We are continuing to actively mitigate the attack at this time and are closely monitoring the performance of the system.
Posted Feb 23, 2023 - 06:23 PST
Update
Our platform is still under an active DDoS attack. We are continuing to apply mitigation tactics and closely monitoring platform performance.
Posted Feb 22, 2023 - 18:32 PST
Update
We are seeing the attack to be shifted to the EU region. We continue to monitor the situation.
Posted Feb 22, 2023 - 13:20 PST
Update
We continue to investigate solutions and are actively monitoring the system.
Posted Feb 22, 2023 - 11:04 PST
Update
DDoS protection remains in place. We are actively monitoring the system.
Posted Feb 21, 2023 - 18:58 PST
Update
We are still seeing reports of some customers having issues. Moving the component status to "Degraded Performance".
Posted Feb 21, 2023 - 13:40 PST
Monitoring
DDoS protection is still in place. We are continuing to monitor the system.
Posted Feb 21, 2023 - 13:08 PST
Update
Implemented DDoS protection and monitoring results.
Posted Feb 21, 2023 - 11:25 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 21, 2023 - 10:33 PST
Update
We are continuing to investigate this issue.
Posted Feb 21, 2023 - 09:50 PST
Investigating
We've been seeing intermittent connection issues to our API and SMTP endpoints located in the US.
Posted Feb 21, 2023 - 07:31 PST
This incident affected: Email Services (API, SMTP).