Delayed logs in US region

Incident Report for mailgun

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 14:04 PDT

Monitoring

Logs are flowing normally and engineers continue to monitor.
Posted Jun 04, 2026 - 13:48 PDT

Update

We are continuing to investigate this issue. Outbound processing, inbound processing, and webhook delivery continue to operate normally.
Posted Jun 04, 2026 - 12:52 PDT

Update

We are continuing to investigate this issue.
Posted Jun 04, 2026 - 11:42 PDT

Investigating

Logs are currently experiencing delays of 15 minutes in Mailgun's US region. Outbound processing, inbound processing, and webhook delivery are operating normally.
Posted Jun 04, 2026 - 11:01 PDT
This incident affected: Email Services (Events & Logs).