Login Errors

Incident Report for mailgun

Resolved

This incident has been resolved.
Posted Nov 14, 2024 - 16:28 PST

Update

Our team has resolved the login issue.
Posted Nov 14, 2024 - 16:26 PST

Investigating

Our team is investigating reports of Login issues for a subset of administrative accounts
Posted Nov 14, 2024 - 15:58 PST
This incident affected: Customer Tools (Control Panel).