Inbound Message Delays
Incident Report for mailgun
Resolved
The delays have been mitigated and the queues are back to normal processing times.
Posted 9 months ago. Sep 06, 2018 - 02:04 PDT
Investigating
We are currently experiencing higher than normal processing times for inbound messages. Delays with routed messages may be experienced.
Posted 9 months ago. Sep 06, 2018 - 01:26 PDT
This incident affected: Inbound email processing.