US Region(s): Elevated SMTP Connection Latency / Timeouts
Incident Report for mailgun
Resolved
This incident has been resolved.
Posted Sep 30, 2024 - 17:29 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 30, 2024 - 16:38 PDT
Investigating
We are currently experiencing elevated timeouts when sending email via SMTP in US regions. Investigation is underway.
Posted Sep 30, 2024 - 13:47 PDT
This incident affected: Email Services (SMTP).