Networking Issues in EU region
Incident Report for mailgun
Resolved
Monitoring has concluded; all systems have resumed normal operations.
Posted 20 days ago. May 28, 2019 - 19:26 PDT
Monitoring
The issue with networking for the EU region has been corrected, and we are now monitoring the situation.
Posted 20 days ago. May 28, 2019 - 18:44 PDT
Investigating
We are currently investigating an issue affecting outbound delivery in the Mailgun EU region.
Posted 20 days ago. May 28, 2019 - 18:16 PDT
This incident affected: Outbound Delivery.