SMTP and API Issues

Incident Report for mailgun

Postmortem

One of our data centers was under a significant DDoS attack resulting in network stability issues across our ORD environment. Mailgun worked with our network security team to mitigate the DDoS and restore availability. During this time, customers may have experienced intermittent connectivity to our control panel, APIs, and SMTP services.

Posted Nov 03, 2015 - 03:25 PST

Resolved

This incident has been resolved.
Posted Nov 03, 2015 - 03:24 PST

Monitoring

The network outage has been addressed; we are monitoring the situation.
Posted Nov 03, 2015 - 02:28 PST

Identified

We are experiencing a network outage in one of our data centers and will switch over all delivery to another DC.
Posted Nov 03, 2015 - 02:16 PST

Investigating

We also currently investigating issue with the API and SMTP endpoints.
Posted Nov 03, 2015 - 01:49 PST