Degraded Performance
Incident Report for mailgun
Resolved
This incident has been resolved.
Posted about 3 years ago. May 19, 2016 - 09:51 PDT
Monitoring
We were able to mitigate the attack. We are monitoring for continued issues
Posted about 3 years ago. May 19, 2016 - 07:36 PDT
Investigating
We are currently experiencing a DDOS that is causing some intermittent packet loss
Posted about 3 years ago. May 19, 2016 - 06:41 PDT