Message delays
Incident Report for mailgun
Resolved
This incident has been resolved
Posted Jun 21, 2017 - 19:01 PDT
Investigating
We are currently investigating an issue that is causing message delays.
Posted Jun 21, 2017 - 14:10 PDT