Deliverability issues to Microsoft domains
Incident Report for mailgun
Resolved
Microsoft has resolved the issue and email is now being delivered normally to their domains Hotmail, Outlook.com, office365, etc. https://portal.office.com/servicestatus
Posted May 25, 2016 - 21:13 PDT
Update
Outgoing email to Microsoft domains unavailable: Hotmail, Outlook.com, office365, etc. are not accepting email traffic at this time due to service issues on their end: (https://portal.office.com/servicestatus). We will continue to retry email sent to these addresses for 8 hours.
Posted May 25, 2016 - 15:12 PDT
Identified
Outgoing email to Microsoft domains unavailable: Hotmail, Outlook.com, office365, etc. are not accepting email traffic at this time due to service issues on their end: (https://portal.office.com/servicestatus). We will continue to retry email sent to these addresses for 72 hours.
Posted May 25, 2016 - 15:09 PDT