Global Internet Connectivity Issues
Incident Report for mailgun
Resolved
This incident has been resolved. Connectivity to Mailgun services has been restored.
Posted Nov 12, 2018 - 15:42 PST
Identified
Some customers are reporting issues connecting to Mailgun services. There is currently a widespread internet outage that may be impacting your ability to reach Mailgun. We are continuing to monitor the situation.
Posted Nov 12, 2018 - 13:53 PST
This incident affected: Email Services (API, SMTP, Outbound Delivery, Inbound email processing, Events & Logs), Customer Tools (Control Panel), and Deliverability Services (Email Validation).