Intermittent Issues/Website
Incident Report for mailgun
Resolved
This incident has been resolved.
Posted Jun 23, 2016 - 12:15 PDT
Monitoring
We had a brief outage between 16:05 - 16:15 UTC due to a DDoS. Our team was able to find the source of the attack and mitigate the attack during this period, and we will continue to monitor our services for any disruption in performance
Posted Jun 23, 2016 - 09:28 PDT