Intermittent Timeouts
Incident Report for mailgun
Postmortem

Yesterday, a small portion of our API requests began failing with 500-level responses and/or connection timeouts between 18:42 – 19:37 UTC and once more between 21:12 – 21:16 UTC. We determined the root cause for this failure was a performance degradation that occurred within our hosting provider's block storage service for one of our availability zones.

Our engineering team is reviewing the details of this incident and will be making monitoring, configuration and system changes that will ensure that failures of this nature are less impactful in the future.

Posted Apr 19, 2017 - 10:26 PDT

Resolved
This incident has been resolved.
Posted Apr 18, 2017 - 17:45 PDT
Monitoring
We are currently monitoring for any further instances and reports of this issue.
Posted Apr 18, 2017 - 15:30 PDT
Investigating
We are currently investigating intermittent timeouts when connecting via the API/SMTP
Posted Apr 18, 2017 - 14:21 PDT