Mailgun ticket system problems
Incident Report for mailgun
Resolved
Zendesk appears to be back online, however, if you are still having trouble creating a ticket, shoot us an email at help@mailgun.com
Posted Oct 13, 2016 - 12:58 PDT
Identified
Our ticketing provider, Zendesk, is currently experiencing trouble. If you have an urgent support need and are unable to create a ticket, please send an email to help@mailgun.com
Posted Oct 13, 2016 - 11:42 PDT