Logs and Events API
Incident Report for mailgun
Resolved
The issue with timeouts and errors concerning the Logs and Events API has been resolved
Posted Nov 15, 2017 - 15:36 PST
Investigating
We are currently investigating timeouts and errors with Logs and Event API
Posted Nov 15, 2017 - 10:12 PST