Slow API response times
Incident Report for mailgun
Resolved
This incident has been resolved.
Posted Sep 13, 2016 - 18:22 PDT
Monitoring
We have implemented a fix and are monitoring the results
Posted Sep 13, 2016 - 16:47 PDT
Investigating
We are currently investigating an intermittent issue that is causing API response times to take longer than usual
Posted Sep 13, 2016 - 14:59 PDT